Mapping failed MapMyCells

Hello dear community!
I am trying to run MapMyCells for annotating my human snRNAseq dataset with the “10x Whole Human Brain (CCN202210140)” as the Reference, but I keep finding the following error:

Mapping Failed
Use log files for troubleshooting MapMyCells issues. Post them in the community forums for further assistance.
Mapping algorithm failed because of application errors.
Please confirm that your input data is in cell (rows) by gene (columns) format.

I also tried with a previously successfully runned mouse scRNAseq dataset and I found the same error with the “10X Whole Mouse Brain (CCN20230722)” reference.

Do someone know if MyMapCells is not working right now? Or how can I solve this problem?

Thanks in advance,



Any chance your browser is still open? Can you post the alpha-numeric RunID of your failed job(s). That will make it easier for us to find the relevant failure logs.

Hello Daniel,

Thanks for the quick response. Here are the IDs:

Run ID: 1720204204941-b151e3ce-4dfe-446e-b965-5633009d277f

Run ID: 1720202547051-29100739-6c16-42b5-8663-60a0fcd8ab94

It looks like numpy released a new version on June 16 that does not play well with anndata.

I will test this hypothesis and update the MapMyCells code to explicitly not install numpy versions >= 2.0.0.

I’ll let you know when that is deployed.

Thanks for catching and reporting this.


It is a little more subtle than what I said.
Among other things: I am having trouble reproducing your error.

Would you object if I downloaded your submitted data file so that I can understand what about it is causing this failure (feel free to say “yes, I would object”)?

No problem, you can download it as long as it is kept confidential. Thanks for your help!

@Pablo_ValderramaC MapMyCells is fixed now.

What was going on:
On June 16, numpy updated to version 2.0.0, which was incompatible with the existing version of anndata. On June 20, anndata released a new version compatible with numpy 2.0.0. MapMyCells last updated somewhere in between those dates, so it did not get the updated version of anndata. We have fixed this problem.

However you are still going to have a problem with your data. The lookup tables that MapMyCells use to go from gene symbols to Ensembl IDs cannot find a single mapping for the gene symbols in your var dataframe (at least for the human dataset). There is some ambiguity in genome version that MapMyCells was not able to resolve. If you go through and change the index of your var dataframe to contain Ensembl IDs, rather than gene symbols, everything should work.

Hi Daniel! Thanks a lot for your help, after being able to change the name of the features to EnsembleID it worked!

Thanks again.