Brain Explorer 2 crashing when visualizing human gene data

Hi Community,

I have been trying to visualize human brain gene expression data in the Brain Explorer 2 desktop software (Mac). I launch the explorer from the human microarray page for a particular gene (e.g. GRB14, see link below). However, the app crashes as soon as it opens without visualizing the gene expression, with the following error message (see below).

I’ve tried 1) redownloading the app, 2) tried to visualise other genes and 3) using different machines (with OSX El Capitan and Mojave) to the same effect.

Does anyone have any fix for this? Thanks!

–PK

1. Link:
http://human.brain-map.org/microarray/search/show?exact_match=false&search_term=grb14&search_type=gene

2. Error message:

Brain Explorer 2 quit unexpectedly.
Process: Brain Explorer 2 [27159]
Path: /Users/USER/Desktop/*/Brain Explorer 2.app/Contents/MacOS/Brain Explorer 2
Identifier: org.alleninstitute.BrainExplorer2
Version: 2.3.5 (2393)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Brain Explorer 2 [27159]
User ID: 507

Date/Time: 2019-07-01 13:28:43.939 +0800
OS Version: Mac OS X 10.11.6 (15G31)
Report Version: 11
Anonymous UUID: E272B2C8-4013-C537-8310-1073D2F98D69

Time Awake Since Boot: 1000000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Application Specific Information:
terminating with uncaught exception of type std::runtime_error: Error while reading data: parse error: premature EOF

abort() called

Global Trace Buffer (reverse chronological seconds):
2.421397 CFNetwork 0x00007fff9ab6bdd8 NSURLConnection finished with error - code -1004
2.421565 CFNetwork 0x00007fff9ab7aeb5 HTTP load failed (error code: -1004 [1:61])
2.422252 CFNetwork 0x00007fff9aaab9c6 TCP Conn 0x101c29020 Failed : error 0:61 [61]
2.422252 CFNetwork 0x00007fff9aaab659 TCP Conn 0x101c29020 complete. fd: -1, err: 61
2.422904 CFNetwork 0x00007fff9ab39f33 TCP Conn 0x101c29020 event 3. err: 61
2.426315 CFNetwork 0x00007fff9aaaa92b TCP Conn 0x101c29020 started
2.429069 CFNetwork 0x00007fff9aa6e56e Creating default cookie storage with process/bundle identifier
2.429069 CFNetwork 0x00007fff9aa6e506 Faulting in CFHTTPCookieStorage singleton
2.429069 CFNetwork 0x00007fff9aa6e395 Faulting in NSHTTPCookieStorage singleton

Hi PK, thanks for the note; we’re able to reproduce the problem and are looking into a solution. Note that this is affecting Windows users as well as Mac users.

Tim

PK,
Thanks for reporting this. We believe the problem should be fixed for all users now. Please let us know if you’re still experiencing an issue.

It works now, thanks!